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Korenix warrants to you, the original purchaser, that each of its products will be free 
from defects in materials and workmanship for five years from the date of purchase. 

This warranty does not apply to any products which have been repaired or altered by 
persons other than repair personnel authorized by Korenix, or which have been 
subject to misuse, abuse, accident or improper installation. Korenix assumes no 
liability under the terms of this warranty as a consequence of such events. 

Because of Korenix’s high quality-control standards and rigorous testing, most of our 
customers never need to use our repair service. If Korenix product is defective, it will 
be repaired or replaced at no charge during the warranty period. For out of warranty 
repairs, you will be billed according to the cost of replacement materials, service 
time and freight. Please consult your dealer for more details. 

If you think you have a defective product, follow these steps: 

1. Collect all the information about the problem encountered. (For example, CPU 
speed, Korenix products used, other hardware and software used, etc.) Note 
anything abnormal and list any on screen messages you get when the problem 
occurs. 

2. Call your dealer and describe the problem. Please have your manual, product, 
and any helpful information readily available. 

3. If your product is diagnosed as defective, obtain an RMA (return merchandize 
authorization) number from your dealer. This allows us to process your return more 
quickly. 

4. Carefully pack the defective product, a fully completed Repair and Replacement 

Order Card and a photocopy proof of purchase date (such as your sales receipt) in a 

shippable container. A product returned without proof of the purchase date is not 

eligible for warranty service. 

5. Write the RMA number visibly on the outside of the package and ship it prepaid 
to your dealer. 
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Declaration of Conformity  

CE 

This product has passed the CE test for environmental specifications. Test conditions 
for passing included the equipment being operated within an industrial enclosure. In 
order to protect the product from being damaged by ESD (Electrostatic Discharge) 
and EMI leakage, we strongly recommend the use of CE-compliant industrial enclo- 
sure products. 

Federal Communications Commission (FCC) Statement 

Note: This equipment has been tested and found to comply with the limits for a Class 
A digital device, pursuant to part 15 of the FCC Rules. These limits are designed to 
provide reasonable protection against harmful interference when the equipment is 
operated in a commercial environment. This equipment generates, uses, and can 
radiate radio frequency energy and, if not installed and used in accordance with the 
instruction manual, may cause harmful interference to radio communications. 
Opera- tion of this equipment in a residential area is likely to cause harmful 
interference in which case the user will be required to correct the interference at his 
own expense. 

 

Technical Support and Assistance 

1. Visit the Korenix web site at www.korenix.com where you can find the latest 
information about the product. 

2. Contact your distributor, sales representative, or Korenix's customer service 
center for technical support if you need additional assistance. Please have the 
following information ready before you call: 

– Product name and serial number 
– Description of your peripheral attachments 
– Description of your software (operating system, version, application software, 

etc.) 
– A complete description of the problem 
– The exact wording of any error messages 

 

 

 

 

 

 

http://www.korenix.com/index.aspx?lang=US
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Safety Instructions  

 Read these safety instructions carefully. 
 Keep this User Manual for later reference. 
 Disconnect this equipment from any DC outlet before cleaning. Use a damp 

cloth. Do not use liquid or spray detergents for cleaning. 
 For plug-in equipment, the power outlet socket must be located near the equip- 

ment and must be easily accessible. 
 Keep this equipment away from humidity. 
 Put this equipment on a reliable surface during installation. Dropping it or 

letting it fall may cause damage. 
 The openings on the enclosure are for air convection. Protect the equipment 

from overheating. DO NOT COVER THE OPENINGS. 
 Make sure the voltage of the power source is correct before connecting the 

equipment to the power outlet. 
 Position the power cord so that people cannot step on it. Do not place anything 

over the power cord. 
 All cautions and warnings on the equipment should be noted. 
 If the equipment is not used for a long time, disconnect it from the power 

source to avoid damage by transient overvoltage. 
 Never pour any liquid into an opening. This may cause fire or electrical shock. 
 Never open the equipment. For safety reasons, the equipment should be 

opened only by qualified service personnel. 
 If one of the following situations arises, get the equipment checked by service 

personnel: 
 The power cord or plug is damaged. 
 Liquid has penetrated into the equipment. 
 The equipment has been exposed to moisture. 
 The equipment does not work well, or you cannot get it to work according to 

the user's manual. 
 The equipment has been dropped and damaged. 
 The equipment has obvious signs of breakage. 
 DO NOT LEAVE THIS EQUIPMENT IN AN ENVIRONMENT WHERE THE STORAGE 

TEMPERATURE MAY GO -40°C (-40°F) ~ 85°C (185°F). THIS COULD DAMAGE THE 
EQUIPMENT. THE EQUIPMENT SHOULD BE IN A CONTROLLED ENVIRONMENT. 
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1.1 Overview 

EtherNet/IP was introduced in 2001, it is the leading proven industrial automation 

communications technology based on standard Ethernet and Internet technology. 

Developed and managed by ODVA, EtherNet/IP is open and supported by hundreds of 

supplier companies. 

EtherNet/IP switches provide Faceplate, Add-on Instruction (AOI), Electronic Data Sheet 

(EDS), so users can easily integrate with Rockwell systems or other EtherNet/IP systems 

to monitor and configure switches. 

ODVA certificated, EtherNet/IP switches are quite simply reliable and rugged. 

1.2 Supported Hardware 

The following is a list of devices supported by the AOI program. 

 

1.3 Requirements 

1.3.1 SCADA Requirements 

 AB FactoryTalk® View v8.0 

1.3.2 Hardware 

 Personal computer with an Intel Pentium 4 processor (2 GHz or faster processor 
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recommended). 

 Memory (RAM): 1 GB (or more) for 32-bit systems. A minimum of 2 GB 

required for 64-bit operating systems 

 Hard disk space: Minimum 1.5 G 

 Human Machine Interface (HMI) requirements: 

– Model: AB 2711P-XXXXXX 

– PanelView Plus 6 (700 or higher) 

– PanelView Plus 7 (700 or higher) 

– Version 8.0 

1.3.3 Operating System 

The host computer must be equipped with any of the following operating systems 

to support the AOI program operations. 

 Windows XP 32/64bit Professional version or higher 

 Window 7 32/64bit Professional version or higher 

 Windows 8 64bit Professional version or higher 

 Windows Server 2012 32/64bit Professional version or higher 

1.4 Configuring the Controller Device 

This section provides a path for configuring and programming the controller device. Once the 

device is configured, the settings are saved to an AOI file for exporting to PLC devices. 

Note! PLC device is required before you can fully configure the device. The included 

software and installation guide for the PLC device from the manufacturer are 

required to fully configure the controller device. 

Two possible methods for configuring and programming are available. The following outlines 

the use of the Logix application and FactoryTalk® View ME, the latter of the two options. 

For further reference, FactoryTalk® View is the application to allow you to generate a user 

interface. Two possible UI types are available, Machine Edition and Site Edition. The ME UI is 

intended for HMI devices, while the SE UI is for a personal computer. 

 

1.4.1 Configuring in Logix 

The Logix application provides the functionality required to create an AOI file. The 

RSLogix5000 v19 or higher is required for this procedure. 

1. Prior to getting started, locate the necessary example file(s) from the 

enclosed CD. 

2. Locate the RSLogix5000 application and open it. 
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3. Once in the main menu, navigate to the File main menu and select Open 

to open an existing file or New to create a new file. 

4. If you selected New, the New Controller window displays. Select the 

hardware architecture for your main board type. See the following image for 

further details. 

– Click the Vendor drop-down menu to select the hardware vendor. 

– Click the Type drop-down menu to select the type of hardware. 

– Click the Revision drop-down menu to select the revisions variable. 

– Tick the Redundancy Enabled field if required. 

– In the Name field, enter the name to identify this controller. 

– In the Description field, enter a brief description to better identify the new 

controller, include items such as location, settings type, etc. 

– Click the Chassis Type drop-down menu to select the chassis type. 

– Use the Slot numeric entry field to identify the slot number. 

– In the Create In field, click Browse to select the directory to save the settings. 

– Click the Security Authority drop-down menu to enable the security authority function. 

If security authority is enabled, the Use only the selected Security 

Authentication and Authorization option is avail- able. Tick the option to set 

authorization and authentication to the selected security authority as configured 

in the Security Authority field. 

5. Click OK to continue. 

 

Note! If a matching file is already present, a prompt displays. Select Yes to replace 

the file or No to return to the previous menu. 
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For 1756 Series users see the following procedures, otherwise continue onto 6: The 

following procedure creates an Ethernet module. 

 Under the I/O Configuration root, right-click on the available configuration and 

select New Module to create an Ethernet controller. See the following figure. 

 

 The Select Module Type screen displays. Scroll down to select the following: 

– 1756-ENBT (1756 10/100 Mbps Ethernet Bridge, Twisted-Pair Media 

 Click Create to continue and create a new controller listing. 
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The newly created Module Properties listing displays, see the following figure. 

 

This ends the procedures specific to the 1756 series. 

Users other than the 1756 series can continue here with the configuration 

procedure. 

6. Select the Ethernet entry and right click on it to open the menu bar. 

7. Select New Module to define the module type, see the following figure. 
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The Select Module Type window displays. 

8. Under the Catalog tab, scroll down to find ETHERNET-MODULE type and select 

it. 

9. Click Close on Create to close the displayed window (optional). 

10.  Click Create to Continue 

 

 

11. Select the General tab to modify the parameters. The Connection and 

Module Info parameters are fixed and aren’t modifiable. 

 In the Name field, enter the module name. In the following figure, K_Module1 is used. 

 Under Connection Parameters, enter the values as shown in the following figure. The 

parameters must match the stated values or the parameters found in the EDS file. 

 Under Address / Host Name, select IP Address and enter the designated IP address 



                     JetLink 2108/2308/2308M User Manual 

value. 

If a secondary I/O Configuration is available, make sure to use a different name for example 

K_Module2. 

 

 

12. Select the Connection tab and set the Requested Packet Interval (RPI) field 

(suggested: 1000.0 ms). 

13. Click Ok to continue and return to the main screen. 

 

14. Click Tasks > MainTask > MainProgram to view MainRoutine. 

15. Right click on MainRoutine submenu and elect Open to display the Rung Rou- tine 

window. 
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16. Select a Rung Ladder and right click on it to open the Properties menu. 

 

 

The Import Rungs window displays. 
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17. Scroll down and select Import Rungs 

Before you can overwrite any of the selected Rung files, select the 

Overwrite Selected Rungs option. 

 

18. Locate the target file and click Import to import the file and continue 

the pro- cess, see the following figure. 
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The Configure Rung Properties window displays. 

 

To configure a single JetLink switch setup, go to “Setting Message Configuration 

Parameters” on page 40. 

For a multiple JetLink switch configuration, see the following: 

– Import a second AOI file. 

– Under TestRoutine (Rungs) > References, locate Tags. 

– Locate and change all tags marked K_Switch1 to K_Switch2, see the following 

figure. 

– Click OK to complete the process. 

 

Users with a single JetLink switch, it is not necessary to alter the Tag references. The 

default values define the single JetLink switch. 



                     JetLink 2108/2308/2308M User Manual 

Once the AOI is created and displays as seen in the following figure. 

19. Locate the property value MSG_IP_Address and click the message configuration 

option (MG_IP1). 

 

20. The Message Configuration window displays. Locate the Communication tab 

and click on it. 

 

The following step is required to set the communication path for the target 

switch. 

21. Locate the Path field and click Browse to open the Message Path Browser.  

22. The Message Path Browser window displays. Select the target switch and click 

OK to continue. 
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The Packet Rate Message windows displays. In this event if the MG_IP1 MSG set- ting is the 

only setting to change, other MSG settings do not require further configura tion. 

c 

23. Once the parameter is configured, download the program to the controller and set it to 

run mode. 

 

1.4.2 Configuring in FactoryTalk® View Machine Edition 

1. Open FactoryTalk® View Studio editor software (v7.0 or higher). 

2. The Application Type Selection window displays. Select View Machine Edition,  

and click Continue. 
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The New/Open Machine Edition Application screen displays. 

3. Select the New tab to create a new file; see the following: 

– In the Application name field, enter the name of the file. 

– In the Description field, type a brief description of the file (optional). 

– Click the Language drop-down menu and select en-US to designate the 

language tag for the file. 

– Enter an application name and click Create to create the new application 

file. 

 

Or 

4. You can open an existing application file, see the following: 

– Click on the Existing tab to view a list of available files. 
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– Select an option from the list in the open panel. 

– Click Open to open the existing file. 

 

5. Once the application file is open, you can add components to the configuration. If 

the explorer window is not open, locate the main tool bar and click View > Explorer 

Window to open the menu tree for the application file. 

6. Under the Graphics folder, locate Images and right-click to open an options menu. 

7. Click Add Components Into Applications. 
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8. The Add Components Into Project window displays. Navigate to the location of 

the source folder located in the included CD or download the required files from 

the web site. 

9. Select all images in the Images folder (.png and .bmp), and click Open to import 

them. 

To view specific supported formats, click the Format drop-down menu and select a 

specific format to display in the body pane. 

 

The images are imported and the main menu displays.  

10. From the menu tree, navigate to Graphics > Global Objects. 

11. Right-click to open the options menu and select Add Component Into Applica- 

tion.... 
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12. The Add Components Into Project window displays. Navigate to the location of the 

global objects source folder. 

 

13. Select the K_Object and HMI_Object files and click Open to import them. To 

view specific supported formats, click the Format drop-down menu and select a 

specific format to display in the body pane. 

14. From the menu tree, navigate to Graphics > Displays. 

15. Right-click to open the options menu and select Add Component Into Applica- 

tion....  

16. The Add Components Into Project window displays. Navigate to the location of 

the GFX Objects source folder. 

17. Select the five files in the GFX folder and click Open to import them.  

 

The GFX files are imported and the main menu displays. 

18. From the menu tree, navigate to Graphics > Parameters. 

19. Right-click to open the options menu and select Add Component Into Applica- 

tion.... 
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20. The Add Components Into Project window displays. Navigate to the location of 

the parameter source folder. 

21. Select K_PARAM1 and click Open to import the files. To view specific supported 

formats, click the Format drop-down menu and select a specific format to 

display in the body pane. 

 

22. Click Open to import the files. 

23. From the menu tree, locate the Communications tab at the bottom of the 

screen. 

24. Navigate to RSLinx Enterprise > Communication Setup and double click to open 

the options menu. 
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25. Select Create a new configuration to create a new runtime configuration. 

26. Click OK to continue. 

 

27. Open RSLinx Enterprise, add a new Device Shortcut. For this example, name the 

device shortcut CLX and select your PLC controller. 

28. Click Apply and Copy from Design to Runtime. 

29. Click OK to continue. 

 

30. In the event that the Device Shortcut is not named CLX in RSLinx Enterprise, 

then the imported parameters file (K_PARAM1), must be modified, see the 

example and figure as follows: 

EXAMPLE: 

– Open the K_PARAM1 file. 

– Change the non-remark line to read as follows: #1=[CLX]K_Switch1 

– Save and close the parameters file. 



                     JetLink 2108/2308/2308M User Manual 

 

31. In the Explorer window, navigate to Application > Create Runtime Applica- tion 

and click on it. 

32. Download the previously created parameter file to the device. 

 

33. Start the Runtime application. 

The runtime application is configured and uploaded to the device effectively 

programming the device through the FactoryTalk® View ME application. 

 

1.4.3 Configuring in ME Image Control Panel 

1. Open human machine interface PanelView Plus. The following screen displays. 
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2. Click Switch and enter the Device Information screen. Different device models are 

represented by their respective images. 

3. On the top right of the screen is a function bar (tool bar), with icons 

representing specific tasks available in the PanelView Plus main menu. 
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4. Click the status  icon to see the status for a selected port. To switch between 

port selections, use the arrow icons to select a specific port. 

 

5. Click the tool  icon to enter the Port Settings menu. 

6. Select the setting to change and use the arrow icons to change the settings. 

7. Click Enter to apply the new setting changes. If the Enter button is not pressed the 

changes do not take effect. 

 

8. If a setting is grayed out, the setting is cannot be modified. 

When ports are disabled, the following options are not available: Auto-Nego, 
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Port Speed, and Port Duplex. If Auto-Nego is Enabled, Port Speed and Port 

Duplex cannot be set. CPU and Port utilization alarm limits are available at the 

bottom of the screen. A numeric keypad displays to allow entry of limit values 

 

9. After entering a value, click the return button to return to the previous 

window. 

10. Click Enter to apply the new setting changes. 

 

Enabling or disabling additional settings, such as the Alarm function, is also 

available through the control panel. 

11. Click the alarm icon to enter the alarm list. If an image is grayed out, there are 

no active alarms. An alarm function is active if the listing is in Red. 

12. Click Enable or Disable to change the status of the selected alarm. 
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1.4.4 Configuring in FactoryTalk® View Site Edition 

1. Open FactoryTalk® View Studio editor software (v7.0 or higher). 

2. The Application Type Selection window displays. Select View Machine Edition, and 

click Continue. 

 

The New/Open Machine Edition Application screen displays. 

3. Select the New tab to create a new file; see the following: 

– In the Application name field, enter the name of the file. 

– In the Description field, type a brief description of the file (optional). 

– Click the Language drop-down menu and select en-US to designate the 

language tag for the file. 

– Enter an application name and click Create to create the new application 

file. 
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Or 

4. You can open an existing application file, see the following: 

– Click on the Existing tab to view a list of available files. 

– Select an option from the list in the open panel. 

– Click Open to open the existing file. 

 

5. Once the application file is open, you can add components to the configuration. If 

the explorer window is not open, locate the main tool bar and click View > Explorer 

Window to open the menu tree for the application file. 

6. Under the Graphics folder, locate Images and right-click to open an options menu. 
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7. Click Add Components Into Applications. 

 

8. The Add Components Into Project window displays. Navigate to the location of 

the source folder located in the included CD or download the required files from 

the web site. 

9. Select all images in the Images folder (.png and .bmp), and click Open to import 

them. 

To view specific supported formats, click the Format drop-down menu and select a 

specific format to display in the body pane. 
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The images are imported and the main menu displays.  

10. From the menu tree, navigate to Graphics > Global Objects. 

11. Right-click to open the options menu and select Add Component Into Applica- 

tion.... 

 

12. The Add Components Into Project window displays. Navigate to the location of the 

global objects source folder. 

 

13. Select the K_Object and HMI_Object files and click Open to import them.  

To view specific supported formats, click the Format drop-down menu and 

select a specific format to display in the body pane. 

14. From the menu tree, navigate to Graphics > Displays. 

15. Right-click to open the options menu and select Add Component Into Applica- 

tion....  
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16. The Add Components Into Project window displays. Navigate to the location of 

the GFX Objects source folder. 

17. Select the five files in the GFX folder and click Open to import them.  

 

The GFX files are imported and the main menu displays. 

18. From the menu tree, navigate to Graphics > Parameters. 

19. Right-click to open the options menu and select Add Component Into Applica- 

tion.... 
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20. The Add Components Into Project window displays. Navigate to the location of 

the parameter source folder. 

21. Select K_PARAM1 and click Open to import the files. To view specific supported 

formats, click the Format drop-down menu and select a specific format to 

display in the body pane. 

 

22. Click Open to import the files. 

23. Create a Data Server: Select the project name, and right click to display Add 

New Server > Rockwell Automation Device Server (RSLinux Enterprise). 
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24. Navigate to RSLinx Enterprise > Communication Setup and double click to open 

the options menu. 

 

 

25. Select Create a new configuration to create a new runtime configuration. 

26. Click Finish to continue. 

 

27. Open RSLinx Enterprise, add a new Device Shortcut. For this example, name the 

device shortcut CLX and select your PLC controller. 

28. Click Apply and Copy from Design to Runtime. 

29. Click OK to continue. 
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30. In the event that the Device Shortcut is not named CLX in RSLinx Enterprise, 

then the imported parameters file (K_PARAM1), must be modified, see the 

example and figure as follows: 

EXAMPLE: 

– Open the K_PARAM1 file. 

– Change the non-remark line to read as follows: #1=[CLX]K_Switch1 

– Save and close the parameters file. 

 

31. To complete the procedure, create a Client link and turn it on. 

 

32. Start the Runtime application. 

The runtime application is configured and uploaded to the device effectively 

programming the device through the FactoryTalk® View ME application. 

 

1.4.5 Configuring in SE Image Control Panel 

1. Open human machine interface PanelView Plus. The following screen displays. 
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2. Click Switch and enter the Device Information screen. Different device models 

are represented by their respective images. 

On the top right of the screen is a function bar (tool bar), with icons representing 

specific tasks available in the PanelView Plus main menu. 

 

 

 



                     JetLink 2108/2308/2308M User Manual 

3. Click the status  icon to see the status for a selected port. To switch 

between port selections, use the arrow icons to select a specific port. 

 

4. Click the tool  icon to enter the Port Settings menu. 

5. Select the setting to change and use the arrow icons  to change the settings. 

6. Click Enter to apply the new setting changes. If the Enter button is not pressed 

the changes do not take effect. 

If a setting is grayed out, the setting is cannot be modified. 

Disabled ports the following options are not available: Auto-Nego, Port Speed, and 

Port Duplex. 

If Auto-Nego is Enabled, Port Speed and Port Duplex cannot be set. 

CPU and Port utilization alarm limits are available at the bottom of the screen. After 

entering a value, click the return button to return to the previous window. 

7. Click Enter to apply the new setting changes. 
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Enabling or disabling additional settings, such as the Alarm function, is also 

available through the control panel. 

8. Click the alarm icon to enter the alarm list. If an image is grayed out, there are 

no active alarms. An alarm function is active if the listing is in Red. 

9. Click Enable or Disable to change the status of the selected alarm. 

 

1.5  EtherNet/IP CIP Objects 

The following section identifies supported Common Industrial Protocol (CIP) 

objects. JetLink serial device server line supports the following monitoring objects 

for PLC and SCADA devices: 

 Identity Objects 

 TCP/IP Interface Objects Ethernet Link Objects 

 Networking Objects 

 Assembly Objects 
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 Message Router Objects 

 Connection Manager Objects 

 Base Switch Objects 

 

1.5.1 Identity Objects 

1.5.1.1 Class Attribute List 

 

1.5.1.2 Instance Attribute Lists 

 

1.5.1.3 Common Service 
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1.5.1.4 GetAttributeAll 

 

1.5.2 TCP/IP Interface Objects 

1.5.2.1 Attribute ID 

 

1.5.2.2 Instance Attribute List 
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1.5.2.3 Common Service 

 
1.5.2.4 GetAttributeAll 
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1.5.3 Ethernet Link Objects 

1.5.3.1 Class Attribute List 
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1.5.3.2 Instance Attribute List 
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1.5.3.3 Common Service 

 

1.5.3.4 GetAttributeAll 
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1.5.3.5 GetAttributeAll-Vendor1 
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1.5.4 Networking Objects 

1.5.4.1 Class Attribute List 

 

 

1.5.4.2 Instance Attribute List 
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1.5.4.3 GetAttributeAll 
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1.5.5 Assembly 

 

1.5.5.1 Class Attribute List 

 

1.5.5.2 Instance Attribute List 
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1.5.5.3 Common Service 

 
1.5.5.4 I/O Data 
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1.5.6 Message Router 

1.5.6.1 Class Attribute List 

 

1.5.6.2 Common Service 

 
1.5.7 Connection Manager 

1.5.7.1 Class Attribute List 

 

1.5.7.2 Common Service 
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1.5.8 Base Switch 

1.5.8.1 Class Attribute List 

 
1.5.8.2 Instance Attribute List 

 

1.5.8.3 Common Service 
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2.1 PROFINET 

2.1.1 Introduction 
PROFINET is the standard for industrial networking in automation. It connects devices, 

systems, and cells, facilitating faster, safer, less costly and higher quality manufacturing. 

It easily integrates existing systems and equipment while bringing the richness of Ethernet 

down to the factory floor. 

PROFINET IO recognizes three classes of devices: 

 IO devices 

An I/O device is a distributed I/O field device that is connected to one or more I/ O 

controllers via PROFINET I/O.  The I/O device is the provider of input data and the 

consumer of output data. 

 IO controllers 

This is typically the programmable logic controller (PLC) on which the automation 

program runs. The I/O controller provides output data to the configured I/O- 

devices in its role as provider and is the consumer of input data of I/O devices. 

 IO supervisors. 

This can be a programming device, personal computer (PC), or human machine interface 

(HMI) device for commissioning or diagnostic purposes. 

 

2.2 Configuring PROFINET 

2.2.1 Enable PROFINET I/O 

The PROFINET function default is enabled in the PROFINET project series. It can 

be configure manually in the Web page. To access this page, click Management > 
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PROFINET > PROFINET Settings. 

 

 

2.2.2 PROFINET Cyclic I/O Data 
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2.3 TIA Portal V13 Integration 

The following steps show how to integrate the switch into a PROFINET network: 

1. Create a PROFINET I/O project in TIA Portal 

Create a PROFINET I/O Ethernet project for deploying environment 

2. GSD file installation 

Import GSD file into the project 

3. Add Devices and configuration 

Search and discover the switch in TIA Portal. Configure PROFINET attributes 

such as IP address, device name and I/O parameters. 

4. Save and load the project into the 

PLC Load this project and into the 

PLC 

5. Watch tables of the Switch 

Use TIA Portal to watch switch attributes 

 

2.3.1 Create a PROFINET I/O project in TIA Portal 

Create a new project. 
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1.3.2 GSD file installation 

Install the GSD file via Options. 

 

Now the Ethernet Switch can be found in the Hardware catalog tree under Other 

field devices > PROFINET IO > Network Components > PROFINET Switch. 

 

1.3.3 Add Devices and configuration 

1. Install the GSD file via Options. 

 

2. Draw the PROFINET IO-system between the PLC and the Switch. 
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3. Assign a device name under the Device view. 
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4. Add Port Link Status to the Module. 

 

1.3.4 Save and load the project into the PLC 

Compile and Download to device. 
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1.3.5 Switch Watch tables 

1. Add a new watch table to Project tree > Devices. 

 

2. Drag I/O(Port_Link_Status_1 > Details View) into Watch_table_1. 

 

3. Monitor via the Online menu. 
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